Back to overview
Downtime
Proxies may be inaccessible to some users.
May 10, 2026 at 4:53pm UTC
Affected services
Proxy Services
Resolved
May 10, 2026 at 4:55pm UTC
All proxies restored to normal functionality.
Affected services
Created
May 10, 2026 at 4:53pm UTC
We're aware of an issue affecting residential and mobile proxies and we're currently invesitgating it. Root cause has been identified and resolution is expected shortly.
Affected services