Back to overview
Degraded

Issue affecting new users attempting to purchase new plans and cryptocurrency renewals

Jun 2, 2026 at 4:47pm UTC
Affected services
Landing Page

Resolved
Jun 2, 2026 at 4:59pm UTC

Root cause has been identified and the issue has been fixed.

Created
Jun 2, 2026 at 4:47pm UTC

We are investigating an issue affecting users who try to purchase new plans or renew via crypto payments.

This has no impact on currently active users or automatic renewals.