Back to overview
Degraded
Proxies degraded for some users
Jun 17, 2026 at 11:04am UTC
Affected services
Proxy Services
Resolved
Jun 17, 2026 at 11:32am UTC
Root cause identified and fixed. All proxies have been restored to normal functionality.
Affected services
Created
Jun 17, 2026 at 11:04am UTC
Some users may notice degraded proxy performance in the form of slower requests, we're investigating the issue and expecting resolution shortly.
Affected services